Alfano Pro Plus Go Kart Computer Repair

Repairing my Alfano Pro Plus after a battery leaked inside it

I figured something was wrong when I put new energiser lithium batteries in my Pro Plus and it was saying low battery. So I took it apart and found that old batteries had leaked all over the circuit board which had fried some of the LEDs. I figured this had caused them to short, which was why I was getting low battery – the broken LEDs were drawing heaps of current. I removed 3 of the LEDs in question and yay it works again! saved me around $300 on a new lap timer. Still possibly screwed… need to try new batteries.
CAM00642th Finished – Back to life!! Note the LEDs on the left are darker aka removed.
CAM00627thNot looking good… 1 LED removed.

CAM00628thTwo left LEDs (and LCD) removed – note all the LEDs on the top, which are actually covered over – obviously the same hardware as the next model up.
CAM00638th Under some shielding I found what I’m gessing are caps – at least two of them are cracked, I didn’t write down part numbers… Maybe I should have fixed this…

CAM00640th After cleaning some of the crap off, the battery fluid really ate at the components. 3 LEDs have been removed, just showing the clean-ish solder pads. I only removed one of the backlight LEDs, since they were all connected in series, so now I don’t have backlighting. I haven’t replaced any of the LEDs, even though there were a bunch of unused LEDs in the unit, as I’m worried about further damaging the unit beyond repair, so they are just left open circuit.
CAM00629th Battery terminals all cleaned off, showing how much damage is left…

I was testing the unit while I was working on it with an ATX PSU using a 3v3 line. The ATX would power off each time I powered on the Alfano – even after removing 3 LEDs, this was a little confusing, so I hooked up 2 AA batteries with the current setting on my multimeter and read what that was saying. Drawing ~ 100 mA when switched on, and 0mA when turned off, as opposed to 1A short circuit, I’ll call that a pass.

 

I was having a hell of a time trying to find a manual for my Pro Plus, since the Alfano website doesn’t have any support at all for the non current products. Google was surprisingly showing very little to do with any of the alfano stuff. This lead me to think this product is not so good, but the hardware itself is very good and I guess they wouldn’t be selling millions of them so that justifies the expense (more than $200 for a USB – IR transciever?!).

Eventually I FOUND A MANUAL… IN ENGLISH! using way back machine, I’ve linked the manual itself, here.

Leave a Reply

Your email address will not be published. Required fields are marked *